<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">

<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="//gmpg.org/xfn/11">
<link rel="pingback" href="https://www.on24.com/xmlrpc.php">

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  // ga('set', 'forceSSL', true);
  ga('create', 'UA-194279-1', 'auto');
  ga('send', 'pageview');

</script>

<!-- Google Tag Manager -->
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-NKPS2G');</script>
<!-- End Google Tag Manager -->

<script src="//cdn.optimizely.com/js/8136870131.js"></script>

<meta name="google-site-verification" content="F1Ee3TX7jchLydaaBAd0DL47upHTZO_m2t-7Fd3wBIQ" />

<title>Webinar Registration Page Do’s and Don’ts | ON24</title>

<!-- This site is optimized with the Yoast SEO plugin v5.0.2 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="A good registration page can make or break your webinar registration numbers. Keep this list of do&#039;s and don&#039;ts in mind when promoting your next event."/>
<link rel="canonical" href="https://www.on24.com/blog/webinar-registration-page-dos-and-donts/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Webinar Registration Page Do’s and Don’ts | ON24" />
<meta property="og:description" content="A good registration page can make or break your webinar registration numbers. Keep this list of do&#039;s and don&#039;ts in mind when promoting your next event." />
<meta property="og:url" content="https://www.on24.com/blog/webinar-registration-page-dos-and-donts/" />
<meta property="og:site_name" content="ON24" />
<meta property="article:section" content="Best Practices" />
<meta property="article:published_time" content="2016-05-18T16:21:16+00:00" />
<meta property="og:image" content="https://www.on24.com/wp-content/uploads/2016/06/blog-post-thumb-3.jpg" />
<meta property="og:image:width" content="1000" />
<meta property="og:image:height" content="667" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="A good registration page can make or break your webinar registration numbers. Keep this list of do&#039;s and don&#039;ts in mind when promoting your next event." />
<meta name="twitter:title" content="Webinar Registration Page Do’s and Don’ts | ON24" />
<meta name="twitter:image" content="https://www.on24.com/wp-content/uploads/2016/06/blog-post-thumb-3.jpg" />
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="ON24 &raquo; Feed" href="https://www.on24.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="ON24 &raquo; Comments Feed" href="https://www.on24.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="ON24 &raquo; Webinar Registration Page Do’s and Don’ts Comments Feed" href="https://www.on24.com/blog/webinar-registration-page-dos-and-donts/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.on24.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='cookielawinfo-style-css'  href='https://11jvfl23vm4l3xirbp1ovizf-wpengine.netdna-ssl.com/wp-content/plugins/cookie-law-info/css/cli-style.css?ver=1.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='on24-style-css'  href='https://11jvfl23vm4l3xirbp1ovizf-wpengine.netdna-ssl.com/wp-content/themes/on24/style.css?ver=4.8' type='text/css' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css'  href='https://11jvfl23vm4l3xirbp1ovizf-wpengine.netdna-ssl.com/wp-content/plugins/wordpress-popular-posts/style/wpp.css?ver=3.3.4' type='text/css' media='all' />
<script type='text/javascript' src='https://11jvfl23vm4l3xirbp1ovizf-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://11jvfl23vm4l3xirbp1ovizf-wpengine.netdna-ssl.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://11jvfl23vm4l3xirbp1ovizf-wpengine.netdna-ssl.com/wp-content/plugins/cookie-law-info/js/cookielawinfo.js?ver=1.5.3'></script>
<script type='text/javascript' src='https://11jvfl23vm4l3xirbp1ovizf-wpengine.netdna-ssl.com/wp-content/themes/on24/js/slick.min.js?ver=4.8'></script>
<script type='text/javascript' src='https://11jvfl23vm4l3xirbp1ovizf-wpengine.netdna-ssl.com/wp-content/themes/on24/js/min/widget-min.js?ver=4.8'></script>
<script type='text/javascript' src='https://11jvfl23vm4l3xirbp1ovizf-wpengine.netdna-ssl.com/wp-content/themes/on24/js/min/main-min.js?ver=4.8'></script>
<link rel='https://api.w.org/' href='https://www.on24.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.on24.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.on24.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://www.on24.com/?p=31440' />
<link rel="alternate" type="application/json+oembed" href="https://www.on24.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.on24.com%2Fblog%2Fwebinar-registration-page-dos-and-donts%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.on24.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.on24.com%2Fblog%2Fwebinar-registration-page-dos-and-donts%2F&#038;format=xml" />
		<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
						<!-- WordPress Popular Posts v3.3.4 -->
				<script type="text/javascript">

					var sampling_active = 0;
					var sampling_rate   = 100;
					var do_request = false;

					if ( !sampling_active ) {
						do_request = true;
					} else {
						var num = Math.floor(Math.random() * sampling_rate) + 1;
						do_request = ( 1 === num );
					}

					if ( do_request ) {

						/* Create XMLHttpRequest object and set variables */
						var xhr = ( window.XMLHttpRequest )
						  ? new XMLHttpRequest()
						  : new ActiveXObject( "Microsoft.XMLHTTP" ),
						url = 'https://www.on24.com/wp-admin/admin-ajax.php',
						params = 'action=update_views_ajax&token=b20826b022&wpp_id=31440';
						/* Set request method and target URL */
						xhr.open( "POST", url, true );
						/* Set request header */
						xhr.setRequestHeader( "Content-type", "application/x-www-form-urlencoded" );
						/* Hook into onreadystatechange */
						xhr.onreadystatechange = function() {
							if ( 4 === xhr.readyState && 200 === xhr.status ) {
								if ( window.console && window.console.log ) {
									window.console.log( xhr.responseText );
								}
							}
						};
						/* Send request */
						xhr.send( params );

					}

				</script>
				<!-- End WordPress Popular Posts v3.3.4 -->
				


<script>
  (function(d) {
    var config = {
      kitId: 'mxf5lpc',
      scriptTimeout: 3000,
      async: true
    },
    h=d.documentElement,t=setTimeout(function(){h.className=h.className.replace(/\bwf-loading\b/g,"")+" wf-inactive";},config.scriptTimeout),tk=d.createElement("script"),f=false,s=d.getElementsByTagName("script")[0],a;h.className+=" wf-loading";tk.src='https://use.typekit.net/'+config.kitId+'.js';tk.async=true;tk.onload=tk.onreadystatechange=function(){a=this.readyState;if(f||a&&a!="complete"&&a!="loaded")return;f=true;clearTimeout(t);try{Typekit.load(config)}catch(e){}};s.parentNode.insertBefore(tk,s)
  })(document);
</script>


<link rel="apple-touch-icon" sizes="180x180" href="https://11jvfl23vm4l3xirbp1ovizf-wpengine.netdna-ssl.com/apple-touch-icon.png">
<link rel="icon" type="image/png" href="https://11jvfl23vm4l3xirbp1ovizf-wpengine.netdna-ssl.com/favicon-32x32.png" sizes="32x32">
<link rel="icon" type="image/png" href="https://11jvfl23vm4l3xirbp1ovizf-wpengine.netdna-ssl.com/favicon-16x16.png" sizes="16x16">
<link rel="manifest" href="/manifest.json">
<link rel="mask-icon" href="https://11jvfl23vm4l3xirbp1ovizf-wpengine.netdna-ssl.com/safari-pinned-tab.svg" color="#5bbad5">
<meta name="theme-color" content="#ffffff">

<!--[if IE]>
  <link rel="stylesheet" type="text/css" href="https://11jvfl23vm4l3xirbp1ovizf-wpengine.netdna-ssl.com/wp-content/themes/on24/ie9.css" />
<![endif]-->

<!--[if lte IE 8]>
  <script type="text/javascript">
  window.location.replace("//www.on24.com/outdatedbrowser");
  </script>
<![endif]-->


</head>

<body class="post-template-default single single-post postid-31440 single-format-standard">

<!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-NKPS2G"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->

  
        <style type="text/css">
          #cookie-law-info-bar { display:none !important; }
        </style>
      
<div id="page" class="site">
  <a class="skip-link screen-reader-text" href="#main">Skip to content</a>

  <header id="masthead" class="site-header" role="banner">
    <i class="hamburger icon-menu"></i>
    <div class="row">
      <div class="column small-12 u-centered">
        <a href="/"><img src="https://11jvfl23vm4l3xirbp1ovizf-wpengine.netdna-ssl.com/wp-content/themes/on24/img/on24-logo-white.png" class="logo" /></a>
      </div>
    </div>
    <div class="header-button-container"></div>
      </header>

  <header class="site-header sticky-header">
    <i class="hamburger icon-menu"></i>
    <div class="row">
      <div class="column small-12 u-centered">
        <a href="/"><img src="https://11jvfl23vm4l3xirbp1ovizf-wpengine.netdna-ssl.com/wp-content/themes/on24/img/on24-logo-white.png" class="logo" /></a>
      </div>
    </div>
    <div class="header-button-container"></div>
      </header>

  <nav id="site-navigation" class="main-navigation" role="navigation">
    <div class="nav-buttons">

      
        
          <a href="http://www.on24.com/login">Sign In</a>

        
          <a href="https://event.on24.com/view/wcc/trialaccount/free/?utm_medium=nav&utm_source=on24website&utm_campaign=FreeTrial">Free Trial</a>

        
          <a href="http://www.on24.com/pricing/?utm_medium=nav&utm_source=on24website&utm_campaign=BuyNow">Pricing</a>

        
      
    </div>
    <div class="clearfloat"></div>

    <div class="menu-main-menu-container"><ul id="primary-menu" class="menu"><li id="menu-item-1856" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1856"><a>Products</a>
<ul  class="sub-menu">
	<li id="menu-item-304" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-304"><a href="https://www.on24.com/products/">Products Overview</a></li>
	<li id="menu-item-345" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-345"><a href="https://www.on24.com/products/webinars/">Webinar Software</a></li>
	<li id="menu-item-32798" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32798"><a href="https://www.on24.com/products/on24-gateway/">ON24 Gateway</a></li>
	<li id="menu-item-411" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-411"><a href="https://www.on24.com/products/on24-intelligence/">ON24 Intelligence</a></li>
	<li id="menu-item-387" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-387"><a href="https://www.on24.com/products/virtual-environments/">ON24 Virtual Environments</a></li>
</ul>
</li>
<li id="menu-item-1857" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1857"><a>Applications</a>
<ul  class="sub-menu">
	<li id="menu-item-160" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-160"><a href="https://www.on24.com/applications/">Applications Overview</a></li>
	<li id="menu-item-1213" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1213"><a href="https://www.on24.com/applications/marketing-webinars/">Webinar Marketing</a></li>
	<li id="menu-item-6372" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6372"><a href="https://www.on24.com/applications/sales-enablement/">Sales Enablement</a></li>
	<li id="menu-item-6371" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6371"><a href="https://www.on24.com/applications/partner-enablement/">Partner and Channel Enablement</a></li>
	<li id="menu-item-6235" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6235"><a href="https://www.on24.com/applications/virtual-training/">Talent Development and Onboarding</a></li>
	<li id="menu-item-529" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-529"><a href="https://www.on24.com/industries/financial-services/">Financial Services</a></li>
	<li id="menu-item-531" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-531"><a href="https://www.on24.com/industries/legal/">Legal</a></li>
	<li id="menu-item-3788" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3788"><a href="https://www.on24.com/industries/life-sciences/">Life Sciences</a></li>
	<li id="menu-item-533" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-533"><a href="https://www.on24.com/industries/professional-services/">Professional Services</a></li>
	<li id="menu-item-3758" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3758"><a href="https://www.on24.com/industries/technology/">Technology</a></li>
</ul>
</li>
<li id="menu-item-1859" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1859"><a>Resources</a>
<ul  class="sub-menu">
	<li id="menu-item-192" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-192"><a href="https://www.on24.com/resources/">Resource Library</a></li>
	<li id="menu-item-3018" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3018"><a href="https://www.on24.com/2017/whereisyourroi/?utm_source=nav&#038;utm_medium=ON24website&#038;utm_campaign=WhereIsYourROI_Q416">Webinar ROI</a></li>
	<li id="menu-item-32639" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-32639"><a href="https://www.on24.com/resources/roi-calculator/">ROI Calculator</a></li>
	<li id="menu-item-228" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-228"><a href="https://www.on24.com/resources/demo-showcase/">Demo Showcase</a></li>
	<li id="menu-item-1214" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1214"><a href="http://blog.on24.com">Blog</a></li>
</ul>
</li>
<li id="menu-item-1858" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1858"><a>About ON24</a>
<ul  class="sub-menu">
	<li id="menu-item-107" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-107"><a href="https://www.on24.com/about-us/">About Us</a></li>
	<li id="menu-item-32440" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-32440"><a href="http://www.on24.com/about-us/frequently-asked-questions-on24/">Frequently Asked Questions</a></li>
	<li id="menu-item-143" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-143"><a href="https://www.on24.com/about-us/careers/">Careers</a></li>
	<li id="menu-item-105" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-105"><a href="https://www.on24.com/about-us/contact-us/">Contact</a></li>
	<li id="menu-item-129" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-129"><a href="https://www.on24.com/about-us/executive-team/">Executive Team</a></li>
	<li id="menu-item-1255" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1255"><a href="http://blog.on24.com/news">Press &#038; News</a></li>
</ul>
</li>
<li id="menu-item-542" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-542"><a href="https://www.on24.com/resources/case-studies/">Customer Stories</a></li>
<li id="menu-item-251" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-251"><a href="https://www.on24.com/events/">Events</a></li>
<li id="menu-item-216" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-216"><a href="https://www.on24.com/resources/upcoming-webinars/">Upcoming Webinars</a></li>
<li id="menu-item-957" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-957"><a href="https://www.on24.com/about-us/contact-us/">Contact Us</a></li>
</ul></div>
    <div class="nav-search-bar">
      <!-- <form role="search" method="get" class="search-form" action="https://www.on24.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form> -->
      <form role="search" method="get" class="search-form" action="//www.on24.com/">
        <label>
          <span class="screen-reader-text">Search for:</span>
          <input type="search" class="search-field" placeholder=" Search" value="" name="s">
        </label>
        <button type="submit" class="search-submit"><i class='icon-search'></i></button>
      </form>
    </div>


          <div class="social-nav">

        
          <a href="//www.twitter.com/on24/" target="_blank"><i class="icon-twitter"></i></a>

        
          <a href="https://www.facebook.com/ON24inc" target="_blank"><i class="icon-facebook"></i></a>

        
          <a href="//www.linkedin.com/company/on24" target="_blank"><i class="icon-linkedin"></i></a>

        
          <a href="//www.youtube.com/user/ON24Inc" target="_blank"><i class="icon-youtube-play"></i></a>

        
          <a href="//www.instagram.com/ON24Inc/" target="_blank"><i class="icon-instagram"></i></a>

        
        <div class="clearfloat"></div>
      </div>
    

  </nav><!-- #site-navigation -->

  <div class="nav-push-outer">
    <div class="nav-push">

     <div id="content" class="site-content">
	
	<section class="blog-content">
	  <div class="u-on24-row row">
	    <div class="u-column-70 u-on24-column blog-main-content blog-post-content">

	    	<p><a href="/blog" class="back-to-blog-home">< Back to Blog Home</a></p>
	      
		    
			    <article id="post-31440" class="post-31440 post type-post status-publish format-standard has-post-thumbnail hentry category-best-practices-virtual-communications category-on24-blog">
			    	<header class="entry-header">
			    		<h1 class="entry-title">Webinar Registration Page Do’s and Don’ts</h1>			    	</header><!-- .entry-header -->

			    	<div class="entry-content blog-post">
			    		
			    		<img class="featured-post-image" src="https://11jvfl23vm4l3xirbp1ovizf-wpengine.netdna-ssl.com/wp-content/uploads/2016/06/blog-post-thumb-3.jpg">

			    						    		<div class="entry-meta">
				    			<div class="tags">
				    			  <p class="block-date">May 18, 2016</p>

	                  <p class="categories"> <a href="https://www.on24.com/blog/category/best-practices-virtual-communications/">Best Practices</a>,  <a href="https://www.on24.com/blog/category/on24-blog/">ON24 Blog</a></p>	                </div>
				    		</div><!-- .entry-meta -->
				    		<p>What if you threw a party, but forgot to invite people? Would anyone show up? Unlikely. Now think of this in the context of your webinar promotions &#8212; are your registration pages up to par for the awesome online event that you are about to throw? A good registration page can make or break your webinar registration numbers. That&#8217;s why I&#8217;ve created a list of do&#8217;s and don&#8217;ts to consider when creating your next registration page:</p>
<h3>DO:</h3>
<ul>
<li><strong>Keep it simple</strong>: Stick to the facts – what, where, and when. Make it as easy as possible for clients and prospects to understand what the topic is and how to register. Make sure date and time is clearly stated, possibly in multiple locations on the page, and double check that is it correct!</li>
<li><strong>Direct users to a strong call-to-action: </strong>While the registration page is a good location for a synopsis of the webinar, the point of the page is really to <strong><a href="http://communications.on24.com/Unlocking_the_Secrets_to_Driving_Webinar_Registrations.html?utm_medium=blog&amp;utm_source=on24&amp;utm_campaign=UnlockingSecretsWC_Q216&amp;utm_asset=OD" target="_blank" rel="noopener">register clients and prospects</a></strong>. Embed the registration form near the top of page, not hidden below paragraphs of text. Use a visibility attractive form in order to direct attention to it.</li>
<li><strong>Use images or videos</strong>: People make decisions with their eyes as well, so be sure to create a visually stimulating page. Use an image specific to the webinar you are promoting, not a generic image without information overlaid. Consider creating a teaser video for the webinar. Not only are videos more interactive and engaging, but incorporating them into your registration pages can help increase your actual registration numbers. We saw a double digit increase when we started doing this!</li>
</ul>
<h3>DON’T:</h3>
<ul>
<li><strong>Write a novel</strong>: To the point above, keep it simple! A long registration page with lots of copy can distract users from your actual call-to-action (<strong><a href="http://www.on24.com/demandtechsummit/?utm_medium=blog&amp;utm_source=on24&amp;utm_campaign=demandtech_q216&amp;utm_Asset=ve" target="_blank" rel="noopener">register</a></strong>!)</li>
<li><strong>Add too many fields to your form: </strong>Form abandonment is real! Long forms can cause users to drop off and may lower registration numbers. Find out what fields are necessary for your data model and CRM tools – try to stick to six or less.</li>
<li><strong>Include incorrect or broken links</strong>: Might sound like a no-brainer, but this is the most important item on this list! If your links are broken or incorrect there is no way for users to register for your webinar. Take time to double check links before launching the page. On the same note, make sure your calendar reminders included in the confirmation page are correct, otherwise people will try to log in to your event at the wrong time or date.</li>
</ul>
<p>Want more webinar registration tips and tricks? Watch as we <strong><a href="http://communications.on24.com/Unlocking_the_Secrets_to_Driving_Webinar_Registrations.html?utm_medium=blog&amp;utm_source=on24&amp;utm_campaign=UnlockingSecretsWC_Q216&amp;utm_asset=OD" target="_blank" rel="noopener">unlock the secrets to driving webinar registration</a></strong>.</p>
			    	</div><!-- .entry-content -->

			    	<div class="post-footer">
			    	  
			    	  <div class="post-author">By <a href="https://www.on24.com/blog/author/bryn-powell/">Bryn Powell</a></div>


			    	  <div class="share-buttons">
			    	  	<p class="share-title">Share</p>
			    	  	<div class="dev-share-buttons" data-share-title="" data-share-text=""><a target="_blank" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.on24.com%2Fblog%2Fwebinar-registration-page-dos-and-donts%2F" class="dev-share-buttons__item dev-share-buttons__item--facebook"><span class="dev-share-buttons__text dev-share-buttons__text--facebook">Share On Facebook</span></a> <a target="_blank" href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.on24.com%2Fblog%2Fwebinar-registration-page-dos-and-donts%2F&text=Webinar%20Registration%20Page%20Do%E2%80%99s%20and%20Don%E2%80%99ts" class="dev-share-buttons__item dev-share-buttons__item--twitter"><span class="dev-share-buttons__text dev-share-buttons__text--twitter">Share On Twitter</span></a> <a target="_blank" href="https://plus.google.com/share?url=https%3A%2F%2Fwww.on24.com%2Fblog%2Fwebinar-registration-page-dos-and-donts%2F" class="dev-share-buttons__item dev-share-buttons__item--google"><span class="dev-share-buttons__text dev-share-buttons__text--google">Share On Google+</span></a> </div>			    	  </div>
			    	  
			    	</div>
			    </article><!-- #post-## -->



		    
	<nav class="navigation post-navigation" role="navigation">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://www.on24.com/blog/5-elements-of-great-webinar-promotion-emails/" rel="prev"><span class="meta-nav" aria-hidden="true">Previous</span> <span class="screen-reader-text">Previous post:</span><div class="post-navigation-item post-navigation-left"><div class="post-navigation-image" style="background-image:url(https://11jvfl23vm4l3xirbp1ovizf-wpengine.netdna-ssl.com/wp-content/uploads/2016/06/blog-post-thumb-8.jpg);"></div><div class="post-navigation-text"><p class="post-nav-direction">Last Post</p><h5 class="post-title">5 Elements of Great Webinar Promotion Emails</h5></div></div></a></div><div class="nav-next"><a href="https://www.on24.com/blog/true-life-epic-webinar-fail/" rel="next"><span class="meta-nav" aria-hidden="true">Next</span> <span class="screen-reader-text">Next post:</span><div class="post-navigation-item post-navigation-right"><div class="post-navigation-image" style="background-image:url(https://11jvfl23vm4l3xirbp1ovizf-wpengine.netdna-ssl.com/wp-content/uploads/2016/06/blog-post-thumb-7.jpg);"></div><div class="post-navigation-text"><p class="post-nav-direction">Next Post</p><h5 class="post-title">True Life: I Had an Epic Webinar Fail</h5></div></div></a></div></div>
	</nav>
	    </div>

			

<!-- Blog Sidebar -->
<div class="u-column-30 u-on24-column">


  <div class="blog-sidebar asset-sidebar">

    <div class="blog-sidebar-search">
      <form role="search" method="get" class="search-form" action="//www.on24.com/">
        <label>
          <span class="screen-reader-text">Search for:</span>
          <input type="search" class="search-field" placeholder=" Search" value="" name="s">
        </label>
        <button type="submit" class="search-submit"><i class='icon-search'></i></button>
      </form>
    </div>

    <div class="blog-sidebar-categories">
      <h4>Categories</h4>
      <select class="categories-dropdown wide">
        <option data-value="none" data-display="Select Category">Select Category</li>

        <option value="https://www.on24.com/blog/category/best-practices-virtual-communications/" >Best Practices</option><option value="https://www.on24.com/blog/category/content-marketing/" >Content Marketing</option><option value="https://www.on24.com/blog/category/engagement/" >Engagement</option><option value="https://www.on24.com/blog/category/marketing-trends/" >Marketing Trends</option><option value="https://www.on24.com/blog/category/on24/" >ON24</option><option value="https://www.on24.com/blog/category/on24-blog/" >ON24 Blog</option><option value="https://www.on24.com/blog/category/on24-wbps/" >ON24 WBPS</option><option value="https://www.on24.com/blog/category/pardot/" >Pardot</option><option value="https://www.on24.com/blog/category/products-solutions/" >Products &amp; Solutions</option><option value="https://www.on24.com/blog/category/uberflip/" >Uberflip</option>

      </select>
      <div class="clearfloat"></div>
    </div>

    <div class="blog-sidebar-topposts">
      <h4>Top Posts</h4>

      
<!-- WordPress Popular Posts Plugin v3.3.4 [PHP] [daily] [views] [custom] [PID] -->

<ul class="wpp-list">
<li><a href="https://www.on24.com/blog/where-is-your-roi/" title="Where is your ROI?" target="_self"><img src="https://11jvfl23vm4l3xirbp1ovizf-wpengine.netdna-ssl.com/wp-content/uploads/wordpress-popular-posts/32356-featured-100x74.png" width="100" height="74" title="Where is your ROI?" alt="Where is your ROI?" class="wpp-thumbnail wpp_cached_thumb wpp_featured" /></a> <a href="https://www.on24.com/blog/where-is-your-roi/">Where is your ROI?</a><div class="clearfloat"></div></li>
<li><a href="https://www.on24.com/blog/the-bottom-of-the-funnel-webinar-marketing-challenge/" title="The Bottom-of-the-Funnel Challenge" target="_self"><img src="https://11jvfl23vm4l3xirbp1ovizf-wpengine.netdna-ssl.com/wp-content/uploads/wordpress-popular-posts/32313-featured-100x74.jpg" width="100" height="74" title="The Bottom-of-the-Funnel Challenge" alt="The Bottom-of-the-Funnel Challenge" class="wpp-thumbnail wpp_cached_thumb wpp_featured" /></a> <a href="https://www.on24.com/blog/the-bottom-of-the-funnel-webinar-marketing-challenge/">The Bottom-of-the-Funnel Challenge</a><div class="clearfloat"></div></li>
<li><a href="https://www.on24.com/blog/3-unconventional-webinars-that-close-business/" title="3 Unconventional Webinars That Close Business" target="_self"><img src="https://11jvfl23vm4l3xirbp1ovizf-wpengine.netdna-ssl.com/wp-content/uploads/wordpress-popular-posts/32314-featured-100x74.jpg" width="100" height="74" title="3 Unconventional Webinars That Close Business" alt="3 Unconventional Webinars That Close Business" class="wpp-thumbnail wpp_cached_thumb wpp_featured" /></a> <a href="https://www.on24.com/blog/3-unconventional-webinars-that-close-business/">3 Unconventional Webinars That Close Business</a><div class="clearfloat"></div></li>
<li><a href="https://www.on24.com/blog/twas-the-marketing-fire-drill-before-christmas/" title="‘Twas The Fire Drill Before Christmas" target="_self"><img src="https://11jvfl23vm4l3xirbp1ovizf-wpengine.netdna-ssl.com/wp-content/plugins/wordpress-popular-posts/no_thumb.jpg" width="100" height="74" title="‘Twas The Fire Drill Before Christmas" alt="‘Twas The Fire Drill Before Christmas" class="wpp-thumbnail wpp_def_noPath wpp_featured" /></a> <a href="https://www.on24.com/blog/twas-the-marketing-fire-drill-before-christmas/">‘Twas The Fire Drill Before Christmas</a><div class="clearfloat"></div></li>
<li><a href="https://www.on24.com/blog/webinar-registration-page-dos-and-donts/" title="Webinar Registration Page Do’s and Don’ts" target="_self"><img src="https://11jvfl23vm4l3xirbp1ovizf-wpengine.netdna-ssl.com/wp-content/uploads/wordpress-popular-posts/31440-featured-100x74.jpg" width="100" height="74" title="Webinar Registration Page Do’s and Don’ts" alt="Webinar Registration Page Do’s and Don’ts" class="wpp-thumbnail wpp_cached_thumb wpp_featured" /></a> <a href="https://www.on24.com/blog/webinar-registration-page-dos-and-donts/">Webinar Registration Page Do’s and Don’ts</a><div class="clearfloat"></div></li>

</ul>

<!-- End WordPress Popular Posts Plugin v3.3.4 -->

    
    <div class="blog-sidebar-buttons">
            
              <a class="blog-sidebar-button contact-sidebar" href="/about-us/contact-us">Contact Us</a>

            
                          
              <a class="blog-sidebar-button newsletter-anchor" href="/newsletter">Sign up for our newsletter</a>

            
            
              <a class="blog-sidebar-button feed-subscribe" href="https://www.on24.com/feed/"><img src="https://11jvfl23vm4l3xirbp1ovizf-wpengine.netdna-ssl.com/wp-content/themes/on24/img/rss.png" class="rss-button">Subscribe to Feeds</a>

            </div>
    
          <div class="main-sidebar">
        
        <h3>Check out these resources</h3>
        
          
            
            <div class="sidebar-box">
              <h5>White Paper</h5>
              <p>ON24 Webinar Benchmarks Report, 2017</p>

              
              
                <a class="btn btn-red" href="https://www.on24.com/resources/assets/webinar-benchmarks-2017/">Check it out</a>

              

            </div>

          
            
            <div class="sidebar-box">
              <h5>White Paper</h5>
              <p>10 Common Webinar Mistakes&#8230; and How to Avoid Them</p>

              
              
                <a class="btn btn-purple" href="https://www.on24.com/resources/assets/10-common-webinar-mistakes/">View Now</a>

              

            </div>

                  
      </div>
    
    


  </div>

</div>
	  </div>
	</section>


	<script src="https://11jvfl23vm4l3xirbp1ovizf-wpengine.netdna-ssl.com/wp-content/themes/on24/js/lightcase.js"></script>
	<script src="https://11jvfl23vm4l3xirbp1ovizf-wpengine.netdna-ssl.com/wp-content/themes/on24/js/jquery.nice-select.js"></script>

	<script type="text/javascript">
	  jQuery(document).ready(function($) {

	    $('a[data-rel^=lightcase]').lightcase();
	    $('.categories-dropdown').niceSelect();

	    $('.nice-select .list li').click(function() {
	      if( $(this).attr('data-value') != 'Select Category') window.location = $(this).attr('data-value');
	    });

	  });
	</script>




    	</div><!-- #content -->

    	<footer id="colophon" class="site-footer" role="contentinfo">

                  <div class="row">
            <div class="column small-12 centered">
              <ul class="social">

                
                  <li><a href="//www.twitter.com/on24/?utm_medium=homepage&utm_source=on24websiteOverview&utm_campaign=Twitter" target="_blank"><i class="icon-twitter"></i></a></li>

                
                  <li><a href="//www.facebook.com/ON24inc/?utm_medium=homepage&utm_source=on24websiteOverview&utm_campaign=facebook" target="_blank"><i class="icon-facebook"></i></a></li>

                
                  <li><a href="//www.linkedin.com/company/on24/?utm_medium=homepage&utm_source=on24websiteOverview&utm_campaign=Linkedin" target="_blank"><i class="icon-linkedin"></i></a></li>

                
                  <li><a href="//www.youtube.com/user/ON24Inc/?utm_medium=homepage&utm_source=on24websiteOverview&utm_campaign=youtube" target="_blank"><i class="icon-youtube-play"></i></a></li>

                
                  <li><a href="//www.instagram.com/ON24Inc/?utm_medium=homepage&utm_source=on24websiteOverview&utm_campaign=instagram" target="_blank"><i class="icon-instagram"></i></a></li>

                
                  <li><a href="//event.on24.com/wcc/r/1211589/6DBBD239F64F872F13BDF0251E7735B0" target="_blank"><i class="icon-bunny"></i></a></li>

                
              </ul>
            </div>
          </div>
        
        <div class="row" id="footer-links">
          <div class="column small-12 medium-3">

                      <div class="footer-col-wrapper">
              <ul>
              <li class="footer-links-title">ON24</li>
                                                <li>
                    <a href="/about-us/">About ON24</a>
                  </li>
                                  <li>
                    <a href="/about-us/careers/">Careers</a>
                  </li>
                                  <li>
                    <a href="/about-us/contact-us/">Contact a Webinar Expert</a>
                  </li>
                                  <li>
                    <a href="/resources/upcoming-webinars/">Upcoming Webinars</a>
                  </li>
                                  <li>
                    <a href="/resources/">Resources</a>
                  </li>
                                  <li>
                    <a href="/partners/">Partners</a>
                  </li>
                                  <li>
                    <a href="http://blog.on24.com/">Blog</a>
                  </li>
                              </ul>
            </div>
                    </div>

          <div class="column small-12 medium-3">
                      <div class="footer-col-wrapper">
              <ul>
              <li class="footer-links-title">Products</li>
                                                <li>
                    <a href="/products/webinars/">WEBINAR SERVICES</a>
                  </li>
                                  <li>
                    <a href="/products/on24-video/">ON24 VIDEO</a>
                  </li>
                                  <li>
                    <a href="/products/on24-intelligence/">ON24 INTELLIGENCE</a>
                  </li>
                                  <li>
                    <a href="/products/virtual-environments/">ON24 VIRTUAL ENVIRONMENTS & VIRTUAL TRAINING</a>
                  </li>
                              </ul>
            </div>
                    </div>

          <div class="column small-12 medium-3">
                      <div class="footer-col-wrapper">
              <ul>
              <li class="footer-links-title">Industries</li>
                                                <li>
                    <a href="/industries/financial-services/">FINANCIAL SERVICES</a>
                  </li>
                                  <li>
                    <a href="/industries/professional-services/">PROFESSIONAL SERVICES</a>
                  </li>
                                  <li>
                    <a href="/industries/life-sciences/">LIFE SCIENCES</a>
                  </li>
                                  <li>
                    <a href="/industries/legal/">LEGAL</a>
                  </li>
                                  <li>
                    <a href="/industries/technology/">TECHNOLOGY</a>
                  </li>
                                  <li>
                    <a href="/industries/government/">GOVERNMENT</a>
                  </li>
                                  <li>
                    <a href="/industries/education/">EDUCATION</a>
                  </li>
                              </ul>
            </div>
                    </div>

          <div class="column small-12 medium-3">

                      <div class="footer-col-wrapper">
              <ul>
              <li class="footer-links-title">Contact</li>
                                <li>USA +1 877 202 9599</li>
                                <li>UK +44 (0) 20 35804410</li>
                                <li>Singapore +65 6679 6176</li>
                                <li>Australia +612 9220 1718</li>
                                <li><a href="mailto:solutions@on24.com">solutions@on24.com</a></li>
                            </ul>
            </div>
          
          </div>

        </div>

        <div class="row">
          <div class="column small-12 u-centered footer-copyright">
            <p><a href="/about-us/tou/">Terms Of Use</a> | <a href="/about-us/privacy-policy/">Privacy Policy</a> | <a href="/site-map/">Site Map</a> | Copyright ©2017 ON24, Inc. All Rights Reserved.</p>
          </div>
        </div>
    	</footer><!-- #colophon -->
    </div><!-- #page -->

  </div><!-- .nav-push -->
</div><!-- .nav-push-outer -->

<div id="cookie-law-info-bar"><span>This website uses cookies to improve your experience. We'll assume you're ok with this, but you can opt-out if you wish.<a href="#" id="cookie_action_close_header"  class="small cli-plugin-button cli-plugin-main-button" >Accept</a> <a href="http://freeelitehelp.on24.com/on24-cookie-policy" id="CONSTANT_OPEN_URL" target="_blank"  class="cli-plugin-main-link"  >Read More</a></span></div>		
		<script type="text/javascript">
			//<![CDATA[
			jQuery(document).ready(function() {
				cli_show_cookiebar({
					settings: '{"animate_speed_hide":"500","animate_speed_show":"500","background":"#0a0a0a","border":"#444","border_on":false,"button_1_button_colour":"#80c04b","button_1_button_hover":"#669a3c","button_1_link_colour":"#fff","button_1_as_button":true,"button_2_button_colour":"#333","button_2_button_hover":"#292929","button_2_link_colour":"#444","button_2_as_button":false,"font_family":"inherit","header_fix":false,"notify_animate_hide":true,"notify_animate_show":false,"notify_div_id":"#cookie-law-info-bar","notify_position_horizontal":"right","notify_position_vertical":"bottom","scroll_close":true,"scroll_close_reload":false,"showagain_tab":false,"showagain_background":"#fff","showagain_border":"#000","showagain_div_id":"#cookie-law-info-again","showagain_x_position":"100px","text":"#ffffff","show_once_yn":false,"show_once":"10000"}'
				});
			});
			//]]>
		</script>
		
		<script type='text/javascript' src='https://11jvfl23vm4l3xirbp1ovizf-wpengine.netdna-ssl.com/wp-content/themes/on24/js/navigation.js?ver=20151215'></script>
<script type='text/javascript' src='https://11jvfl23vm4l3xirbp1ovizf-wpengine.netdna-ssl.com/wp-content/themes/on24/js/skip-link-focus-fix.js?ver=20151215'></script>
<script type='text/javascript' src='https://11jvfl23vm4l3xirbp1ovizf-wpengine.netdna-ssl.com/wp-includes/js/comment-reply.min.js?ver=4.8'></script>
<script type='text/javascript' src='https://11jvfl23vm4l3xirbp1ovizf-wpengine.netdna-ssl.com/wp-includes/js/wp-embed.min.js?ver=4.8'></script>

<script src="https://11jvfl23vm4l3xirbp1ovizf-wpengine.netdna-ssl.com/wp-content/themes/on24/js/min/jPushMenu-min.js"></script>
<script>
jQuery(document).ready(function($) {
  $('.hamburger').jPushMenu();
});
</script>

</body>
</html>
